DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 4 of 4 Posts

·
Registered
1997 mitsubishi eclipse gst
Joined
·
4 Posts
Discussion Starter #1
Hey everyone so i bought a 1997 mitsubishi eclipse gst a few months back fully built but it has a bunch of cut wires so the first time i tried to drive it a radiator hose came undone and splashed everywhere then the car didn’t want to start then i noticed that the engine moteur fuse kept popping every time i tried turning it on then i started hearing a buzzing noise which i’m pretty sure is the mpi relay so i followed the wire from engine moteur fuse which i later found out it that it led me to the mpi relay which keeps buzzing and i don’t know why now every time i try turning the key it just cranks but doesn’t turn on but when i give it a little starting fluid it turns on for a little bit then dies I took it to a shop and they said it wasn’t getting fuel but they couldn’t fix it don’t want to sell it but if I can’t fix it i have no choice too does anyone have an answer or clue for me? Thank you!
 

·
Registered
Joined
·
1,381 Posts
What does fully built mean? What wires are cut? Why was the radiator hose loose?

Post a pic of your engine bay.

Your mfi relays shouldn't buzz. Is there any fuel pressure in the fuel line. If it is "built" there should be an aftermarket fuel pump installed and it "should" be wired with bigger than stock wiring and an aftermarket relay is probably buried somewhere in the car.

If it was me, I'd buy a good manual and start going through the wiring. Sounds like the last guy probably dicked something up or did some sketchy wiring repairs. Eagle talon factory service manuals are super cheap on ebay, usually less than a chilton of haynes. They are the best.
 

·
Registered
1997 mitsubishi eclipse gst
Joined
·
4 Posts
Discussion Starter #3
Here’s a pic but idk exactly which wires go where but im still getting fuel pressure so i don’t know what the problem could be the shop that i took it too said i wasn’t getting any fuel


33965
 

·
Elite DSMtalker
Joined
·
694 Posts
I think you need to get a full spec list from the seller. What all was done to the car. Sounds like some fluid might have gotten to areas it shouldn't have. this could cause anything from shorts, to loosing tune, to...well..a lot of stuff.

Also, I'd say...ask the previous owner to help with troubleshooting it.
 
1 - 4 of 4 Posts
Top