DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
223 Posts
Discussion Starter #1
ok first, the tb cable is getting stuck inside the plastic tube behind the intake mani. happened earlier today, i could go under the hood and pull it back out and then start the car and the idle would be normal... it would get stuck open if i gave it any gas so i didnt drive but it would idle fine. so i pulled the cable back out and left the car parked.

went out to smoke a cig and decided to mess with the cable again... but now the idle is around 4 grand and i cant pull the cable out. if i give it any gas then the cable does get stuck but i duno why the idle is so high now. any ideas?
 

·
Registered
Joined
·
1,333 Posts
but now the idle is around 4 grand and i cant pull the cable out. if i give it any gas then the cable does get stuck but i duno why the idle is so high now. any ideas?
Well, if the throttle is cracked open that will happen. Shut it manually.

My car did the same thing but the problem is the TB is gummed up or something. I put a brake pedal return spring on the TB and it has been fine for months. I have pictures.
 

·
Registered
Joined
·
223 Posts
Discussion Starter #5
95tsi, can u post those pictures?

i ordered the cable saturday, actually. hopefully it'l be in tusday.
 

·
Registered
Joined
·
1,333 Posts
GSXguy said:
95tsi, can u post those pictures?

i ordered the cable saturday, actually. hopefully it'l be in tusday.
My problem was mostly from the cruise control actuator contracting when hot but the TB spring is a little weak and did it with the CC disconnected. I took all the cables off and verified they were free.

I am lazy, so this is my temporary permanent fix.

TB helper spring
 

·
Site Administrator
Joined
·
7,762 Posts
If you want to not ghetto it, take the nut off, wind the inner green spring 1 more time inside the outer white spring and then reconnect, it will pull the tb closed with more force.
 

·
Registered
Joined
·
1,333 Posts
K_Mans_TSI said:
If you want to not ghetto it, take the nut off, wind the inner green spring 1 more time inside the outer white spring and then reconnect, it will pull the tb closed with more force.
I'm glad you guys liked it:p .

I thought about winding the spring around another time but like you said, I would have to take the nut off.
It is temporary like I said, I don't have a garage or anyplace to really(street) work on my car so I like to get things done quick:rolleyes: . I will fix it the correct way someday...

It isn't really bad the way it is, the gas is a little harder to push but I can live with it. Its better than 3500 idle.

I am waiting for a break in the weather for a 50+ degree day so I can get my turbo and 3" back installed, I might be waiting a while
:(
 

·
Site Administrator
Joined
·
7,762 Posts
When i did mine i was changing my throttle body anwyays so it wasn't a problem.
 
1 - 10 of 10 Posts
Top