DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 3 of 3 Posts

·
Premium Member
Joined
·
17,457 Posts
Discussion Starter · #1 ·
Hey, I have a sudden problem with very unreliable boost. I have a 4 year old extreme xbc that I think may be on its way out but lets see what you guys think. I have the xbc set to 17#. It was always very stable and rarely if ever spiked. Suddenly when I go wot it spikes to about 20# and then drops all the way to about 11 and stays there. It doesn't matter what boost I run. I have made no mods that would effect this (intake, intercooler, or pipes) and have checked the entire intake system by pressurizing it and have found no leaks at all. I figure the mbc is going south but I am not sure. Car feels strong still but I need more pressure.

------------------
1995 Talon TSI fwd
 

·
Registered
Joined
·
7 Posts
I have a '95 Eclipse GS-T, same model as yours with same mods too. I have an upper IC pipe, intake, catback and BOV. My MBC that i made from VFAQ.com worked for a little bit and now it has the same problem. It spikes to 20 PSI and then sets down at 12-14. I think the problem is within the MBC. I took mine out and found out that the screw that adjusts boost is sometimes a little off after a couple days of cranking boost up and down. The ball and spring design in mine is weird. I think that it is just the flow that goes through the MBC. The screw is set where it doesn't really adjust boost but rather just intimidates it with high PSI and then drop. It could most likely be the spring inside the MBC. ry replacing it before buying a new one.
 
1 - 3 of 3 Posts
Top