DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter · #1 ·
I'm in the middle of upping the boost in my talon. I'm having trouble with boost control.

Mods:
92 Talon Tsi 6bolt, 4bolt combo
Punishment racing fmic
rewired fuel pump
evo3 16g ported
ported 2g manifold
ported 2g o2 housing.

My punishment racing kit didn't come with a nipple on the intercooler pipe for a waste gate line. Before i put my fmic in, i had no problems with boost. I ran on the stock boost control (factory) and stayed at 10psi no problem. No boost creep nothing. With the new pipe i went out and got a brand new boost controller. I hooked up the boost controller the bottom line going to my vaccum line between the manifold and bov. And the other line going to the wastegate. When i set it for lowest boost possible IE turned all the way in or on the top where it says "lower" and the arrow and direction i hit about 15psi of boost then it spikes up to around 20psi and i push the clutch in before i melt pistons. I hit fuel cut at around 25psi i found out also. Why am i getting such high boost? I switched the 2 lines and got waaay worse boost. Like going way over 20psi.

Could it be my boost controller is ass backwards. Now that i think about it it said for the wastegate line to be on the bottom except that thats the line that has to PUSH the ball and spring to create boost correct? There for the top line would determine the amount of boost because of the pressure. I know thats backwards from the sticker that they put on it. And now that i think about it even more having it all the way to "lower" by tightening the mbc just makes it so more boost has to push the spring. So really wouldn't letting it up or undoing it cause less boost.

BRB i'm going for a drive.
 

·
Registered
Joined
·
2,420 Posts
If I'm reading this properly, you tapped into the vacuum line for the BOV. This is part of your problem.
 

·
Registered
Joined
·
3,116 Posts
First make sure that your mbc is set this way. Just ignore the line going from the solenoid to the intake.



Then remove the vacuum line that you tapped to your bov, that is a big no no, I think that if you don't have a nipple on your turbo (do 16g's have a nipple?) you are supposed to drill a hole on your intercooler piping and tap the vacuum line there. Also what kind of mbc are you using? could be a weak spring or overall crappy mbc. Come back to us if this doesn't resolve your overboosting issue.
 

·
Registered
Joined
·
1,296 Posts
frankozz said:
First make sure that your mbc is set this way. Just ignore the line going from the solenoid to the intake.



Then remove the vacuum line that you tapped to your bov, that is a big no no, I think that if you don't have a nipple on your turbo (do 16g's have a nipple?) you are supposed to drill a hole on your intercooler piping and tap the vacuum line there. Also what kind of mbc are you using? could be a weak spring or overall crappy mbc. Come back to us if this doesn't resolve your overboosting issue.

+1,

Love the Diagram of the install is that for a HKS Boost controller? JK!:p
 
1 - 6 of 6 Posts
Top