DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter #1
Was on the road last night. Overdrive was on and I had the throttle at about 70ish percent when all of a sudden I heard a pop. It seemed like the car just stopped for less then a second then started back up again. It was almost like a backfire now that I remember it. A couple pops came after thee first time it did it and then I slowed down.

My air/fuel gauge was in the normal position and my EGT's were at about 1450. Boost is set at 18psi, but I wasn't at full boost.

Does this sound like fuel cut or something else? I have a walboro fuel pump with stock injectors.
 

·
Registered
Joined
·
1,199 Posts
no its not fuel cut. that is different. feels like brakes almost. your intercooler pipe didnt blow off did it? actually never mind that...you said it happened a few more times. was it just a backfire?
 

·
Registered
Joined
·
1,157 Posts
it sounds like a fuel cut type of problem but that doesnt make sense with what you described. a glitch in the ecu? weird
 

·
Registered
Joined
·
1,157 Posts
backfire? was there any reason it would be running rich?
 

·
Registered
Joined
·
150 Posts
Discussion Starter #6
I have a front mount intercooler. All the pipes are solid and good. I can't think of a reason why it would be running really rich. My AFC is somewhat tuned. At full boost, my EGT's get up to about 1500-1550.

I also have one range colder plugs to prvent detonation.
 
1 - 7 of 7 Posts
Top